Allgemeine Informationen über unsere eXtensions und Templates für Joomla



Verfügbarkeit unserer eXtensions und Templates


Alle unsere eXtensions und Templates werden für die Version 2.5.x , die derzeitige LTS (long term support) von Joomla, produziert. Wenn nicht anders ausgewiesen, funktionieren alle eXtensions mit dieser Version. Wir produzieren nur (auf und) für LTS Versionen, allerdings werden unsere eXtensions und Templates auf STS Versionen angepasst, zeitliche Verzögerungen sind dabei leider unvermeidlich.

Die Gründe auf eine LTS Version zu setzen sind einleuchtend:


  1. eine LTS Version ist immer als stable markiert
  2. längere Supportzeiten
  3. OSM, die Organisation hinter Joomla, empfiehlt die Verwendung von LTS Versionen
  4. OSM schreibt auf der Joomla-Seite :

    Zitat: "Joomla 3.0 is recommended for more experienced users and developers. It includes cutting edge features." oder in deutsch übersetzt: Joomla 3.0 ist für erfahrene Anwender und Entwickler empfohlen. Es beinhaltet teilweise noch nicht getestete Funktionen.

  5. aus den kurzen Supportzeiten einer STS (short term support) resultiert zwangsläufig die Notwendigkeit öfter Updates einzuspielen als bei einer LTS.

Dies ist ein Kostenfaktor für Seitenbetreiber, da es nicht nur den Joomla-Kern betrifft, sondern auch alle zusätzlich installierten Erweiterungen. Bei einem Update sollte im Vorfeld durch ein lokales Testupdate geklärt werden, ob alle installierten Erweiterungen nach dem Update noch einwandfrei funktionieren oder ob ungewollte Inkompatibilitäten auftreten. Nichts ist schlimmer als ein schiefgegangenes Update, oft bleibt in solch einem Fall nur noch die Möglichkeit ein Backup wieder einzuspielen.

Natürlich wollen wir niemanden davon abhalten, Joomla 3.0.x (STS) zu testen oder produktiv einzusetzen, wir raten lediglich dazu, diese Entscheidung nicht zu überstürzen.

Weshalb werden unsere eXtension nicht (mehr) für Joomla 1.5.x angeboten?


Wir haben den Support und Verkauf unserer Erweiterungen für Joomla 1.5.x zum 30. Juni 2012 eingestellt. Joomla selbst hat den Support für die Version 1.5.x bereits zum 24. April 2012 eingestellt. Diese Joomla Version wird somit weder weiterentwickelt noch mit neuen Sicherheitsupdates versorgt. Konkret bedeutet dies: falls eine potentielle Sicherheitslücke im 1.5.x System entdeckt wird, wird diese nicht mehr geschlossen. Eine Joomla 1.5.x Seite könnte somit zum Sicherheitsrisiko werden und kann möglicherweise gehackt werden. Dies ist natürlich ein worst-case Szenario, aber auch hier gilt : "Vorbeugen ist besser als heilen". Falls Sie also noch eine Seite mit Joomla 1.5.x betreiben, sollten Sie ein Upgrade auf eine neuere Version in Erwägung ziehen.